migrating from IDE to SATA hdd

Live forum: http://forum.freeipodguide.com/viewtopic.php?t=68036


10-08-2007 21:52:20

this is really aggrevating. i had two IDE drives. took one out (it's just data) and put in my new SATA. it wasn't being detected so i downloaded the sata drivers from nvidia's website (it's an nforce4 mobo). installed those (it's also a full update of other drivers as well. the system came with sata drivers on a floppy, but i have no flopp drive), and then it was being detected. i cloned my C drive from the IDE to my SATA. made the SATA the boot drive but the computer never boots. it never goes to the boot menu even (there was a vista install on the HDD i removed, but i never use it).

did some googling and people are some people are saying you hafta install the sata drivers during windows setup for them to work on a boot drive (some people say as long as you install them to the ide drive before cloning it's fine). well, i can't do that even if i wanted to install windows fresh, because like i said, i don't have a floppy drive.

wth am i supposed to do? i never imagined it'd be this hard. someone said on a page i found that if you do a repair install of xp on both partitions (or i figure just on the sata) that it'll solve it. but you lose all xp updates you've installed and who knows what else. and that may not even work.

surely there's a simpler way. if not someone responsible for this mess needs shot...

oh, and the threads i found


11-08-2007 07:21:15

Unless you're doing RAID, nForce4 chipsets shouldn't require drivers to see a SATA drive. SATA is native to the BIOS and chipset. You don't even need F6 drivers when installing Windows, it just sees it as a standard drive automatically.

Have you gone into the BIOS setup and enabled the SATA ports? Disable RAID mode on the port(s) you're using.

The XP repair install works well, I've used it numerous times to restore a hosed XP installation. It doesn't delete your apps or anything, you just lose any Windows Updates you might have applied.


11-08-2007 10:47:22

it wasn't detecting it til i installed the driver updates, so i dunno. i had checked that the ports were enabled and everything.
the mobo did come with drivers on a floppy and the book said they had to be installed even if you weren't gonna use raid, if your primary drive was gonna be a sata.
i don't actually see an option to disable raid.

now i have bigger problems. someone suggested i run chkdsk /r, fixboot, and fixmbr. sounded plausible tho i didn't expect it to fix my problem. i started it anyways and chkdsk was taking hours, and it was at 70% when i was going to bed, so figuring it's just reading files and checking for fragments or something, i hit the power button on my system and was gonna reboot and run the other commands. dind't figure chkdsk was gonna help me much. well, upon rebooting and picking from the boot menu (the ide), i get an error saying windows can't start cause system32/hal.dll is missing or corrupt.

i booted up bartpe and copied the file off my sata drive back onto the ide (it wasn't missing and it was the same size, so i don't think it wasn't corrupt). still get the same error when i try to boot.
(just now did the other commands but of course i still get that error)

so what if i wanted to keep my ide as the boot drive and simply boot the Windows off my sata by setting it up in my boot.ini (i removed the vista boot loader)? i can't figure out the correct path to it. the path to my ide for example is

multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Micro soft Windows XP Professional"

but anything i try for the sata doesn't work. the bootloader freezes when i even highlight the second option i add. it's on sata channel 3 (it was labeled 1 in the mobo book but bios says it's 3). and it's partion 1 atm (i accidentally cloned it with space in front - which is the default for some reason - this last time time, so it did something weird and added an extended partion and all this. but the first time i cloned it did it the way i want, was the only partition on the drive, but still wouldn't work with anything i tried.)


11-08-2007 10:58:54

I have an nForce4 mobo and the boot drive is a SATA drive. No drivers required at all. Some nForce4 mobos have additional SATA controllers for extra drives -- mine has an extra Silicon Image controller. That one DOES require drivers. You sure you're plugging into the native nForce4 ports?

Regardless though, even if yours required drivers, it should still boot if you supply the drivers to the XP install via floppy. If you don't have and cannot borrow a floppy, it is possible to build a new XP install disc with the drivers included. It'll obviously require a bootable PC with an internet connection and a CD burner. Google for slipstreamed or unattended Windows XP disc creation.

Here's the site and process I always used


But before you go that route, make sure your SATA ports require drivers. Unless you have a really old or really weird nForce4 mobo, you should not need drivers.


11-08-2007 11:19:25

well, i have that dual-boot config, so actually it boots according to what's in it, and i think that may be the prob. i could disconnect the drive and then remove my bootloader somehow, and it may work, but i dunno.
i definitely can't start with a fresh install of windows. it'd f up my software development environment and that's a gigantic pain in the ass. i might resort to a repair install. i guess if it does something too bad i could revert back to my ide drive (if i can figure out my new missing/corrupt dll problem...).

any idea how i would set up the boot.ini to have an option for each the ide and the sata partitions?

oh, and my mobo only has 4 sata connections, all the same.


11-08-2007 11:37:04

I think your problem comes from the clone.

A repair install is completely harmless, I've done them dozens and dozens of times.

What sort of dev environment do you have that wouldn't survive a clean install? I wipe and install new OS's all the time and don't have problems moving any of my dev environments around.

One thing I'd recommend is leave only the OS(es) on C drive. Create a D partition or add a D drive and install everything to that. It makes OS repairs and reinstallations a helluva lot less painful. I've been using the C/D scenario for 10 years and would never go back, and I've converted quite a few folks over to it who love it. If you're the type like me that constantly upgrades and wrenches on your system, it's a huge timesaver. I format and re-install Windows from scratch at least twice per year, sometimes more often.


11-08-2007 11:40:59

i program in VB6 and the way it handles active-x controls is a nightmare. moving it from windows 98 to xp was awful. it gets the class ids all messed up and you hafta go into the registry and find em and change those in your vb project by hand, because opening the project in vb removes all instances of that missing control, etc...

i cloned my drive with acronis disk manager or something like that. should be a good product.


11-08-2007 11:46:12

Acronis TrueImage, and yes it's a great product. I bought it myself and use it quite often.

Ah, nasty old VB. Hate it with a passion. In the old days of VB4 (the early days of ActiveX/OCX controls) DLL Hell was a common occurrence, but it's supposed to have gotten better since (although VB6 is still pretty old).

If you know the registry tree entries you could back them up and restore them, but that's about as much advice as I could give you with regards to VB. Like I said I avoid it (and all Microsoft development tools, with the exception of some C++ stuff and that's only because Borland dropped the ball with all of us C++ loyalists) like the plague nowadays.


11-08-2007 11:47:40

actually not trueimage. i have that too, but there's another that's for partitioning/etc instead of backup.


11-08-2007 12:08:13

Although I put it off for a long time because of all of the problems I've read, I went from IDE to SATA for my boot drive using Acronis true image with no problems so give it a try since you have it. It might've taken care of the SATA driver for me.


11-08-2007 13:32:43

well, this is interesting i renamed the boot.ini, the comp boots, says "invalid boot.ini, booting c\windows" and then it successfully boots the ide drive, with no hal.dll error.
so, i think that the paths in my boot.ini are simply no longer valid (i have after been using the vista bootlader for quite some time, plus i removed that other drive and added a new one).

i then renamed the boot.ini on the sata drive then disconnected the ide. i also now have the sata on sata channel 1. it boots and of course lists the sata drive during POST, first listing it's size, then enabling SMART, but it never goes past POST. wth?


11-08-2007 14:12:52

[quote9587129dbd="gnznroses"]actually not trueimage. i have that too, but there's another that's for partitioning/etc instead of backup.[/quote9587129dbd]
Ah, Disc Director. I have that too, I thought you were talking about the clone tool. Yeah, I bought the Suite that includes DD and TI together. Great set of tools to have in the kit.


11-08-2007 14:16:29

i just don't understand this. nothing i try in boot.ini will boot EITHER drive, yet it'll boot the ide if the file is missing. here's the options i have in my boot.ini

multi(0)disk(0)rdisk(0)partition(0)\WINDOWS="Microsoft Windows XP Home Edition" /NOEXECUTE=ALWAYSOFF /FASTDETECT

the top option gives the hal.dll error, the others just freeze up the boot menu.

i would try a repair install of xp but i don't think it'd work. if i do it to the sata drive, i don't think that'll do much good, if the drive won't boot. so if that doesn't work and i choose to do it to the ide drive (which is actually working ok by itself), then i've just kinda messed up both and wouldn't have a backup of the way it was. so i would want to do it to one or the other, but not both, because if it doesn't work i want to just restore things how they were.
i dunno what to do. it should work to boot the ide but choose an option at the boot menu to boot the windows install that's on the sata. then nothing gets messed up either.


11-08-2007 14:31:35

sorry for all the posts, but i think i fixed it )
found a post on another forum that helped. i did the fixboot and fixmbr, but the trick is to do it with only the sata drive plugged in.