Makes a bleep noise when I try to initiate trade wont let me

Live forum:


13-02-2007 23:33:00

When I click initiate trade, It makes a bleep sound and redirects me to a page that says I could be doing my own initiate trade. I've tried it to a bunch of different users to test it and it does not work. I turned off my popup blocker and accept all cookies and it still does not let me initiate trades. Any advice. I have the new Internet Explorer. Are there any settings i need to tweak?


13-02-2007 23:54:28

I assume you are clicking on the link in the profile for the person who you are trying to trade with? If you are, then I don't know.


13-02-2007 23:56:58

yes i am clicking initiate trade in their profile.. this is what i get
Failed. This can happen for several reasons
- You tried to initiate a trade with yourself
- You included a link in the subject (add it later in the "notes" field)
- Your subject was too short. Make it meaningful.
.. Do I need to close a program or something I may have open in a diff window? Plus.. also It says something will pop up so I may leave feedback and that never happens..


14-02-2007 00:01:09

I don't know why you can't initiate trades, then. But the feedback input should pop up when you try to change a trade status to Requesting TR. It might be venerable to pop-up blockers if this is the case. Make sure you are allowing pop-ups on this site.


14-02-2007 06:05:51



14-02-2007 06:07:35

Thanks TTGP, I definitely appreciate you posting the link to help. +Karma

However, this link goes directly to TSJ's thread, to save people the extra click.